Категории заданий

Нужна EXCEL формула для ключевиков

Алексей Бахтюков Исполнитель: Алексей Бахтюков 
Оценка: +1
Отзыв: 
Стоимость: 300
Категория: Реклама и соц.сети
Время выполнения: 12 мин
Поиск кандидата: 0 сек


Подробное описание:

У меня есть 2 столбца. clip2net.com/s/3picg5R. Есть формула =ЕСЛИ(СЧЁТЕСЛИ(A:A;СЦЕПИТЬ("*";B1;" *"))>=1;2;1) Она, по идее, должна поставить число "2" напротив тех слов в столбце B, которые не содержатся в столбце A а тем, которые содержатся – число 1, но у меня она, почему то, всем ставит 2. Уже было такое, потом автор формулы вес поправку, а я её посеял. Цитата автора формулы: "По формуле косяк может быть на пробелы (эксель бывает, что считает счётесли не с первого символа – столкнулся на схожем проекте. КОСЯК ЭКСЕЛЯ). Чтоб обойти, предлагаю в C1 поместить =сцепить(" ";A1:" ") (к фразе с каждой стороны приписываем по 2 пробела), протягиваем по столбцу. ОЧЕНЬ ЖЕЛАТЕЛЬНО закрепить кроме первой ячейки (копировать, вставка значений). Первую не трогаем чтоб не переписывать формулу в следующий раз (в закрепленных ищет надежней) – чтоб уж совсем подстраховаться. а поисковую формулу пишем в D1 =если(счётесли(A:A;сцепить(" ";B1;" "))>=1;"встречается";"не встречается")" Но я вставляю =сцепить(" ";A1:" ") и ексель не воспринимает её за формулу. Он мне кидал готовый эксель файлик, в котором она уже была вбита. вот его я и посеял ;) Надо либо восстановить эту формулу, либо написать альтернативную. Если слово в столбце B содержится среди слов в столбце A -> ставим напротив него "Содержится". Если не содержится -> ставим "Не содержится".

Рассказать друзьям

Подпишитесь на полезные статьи

Примеры заданий и практические советы по аутсорсингу задач

   



На дайджест уже подписалось 555214 читателей!

Присоединяйтесь к нам в соцсетях!